• 关于国内某个软件代理商代理的CorelDRAW系列软件,如果各位需要正版请访问corel官方网站,不要访问带有china的网站!!!反正话是放在这里了,听不听随你
  • 感谢访问,请访问https://alipay.vnas.me领取支付宝红包
  • 如果遇到文章图片不显示请联系管理员处理,谢谢
  • 欢迎访问寡人的吐槽胜地,我们真的只是吐槽,不谈技术,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站
  • 感谢访问,请访问https://alipay.vnas.me领取支付宝红包
  • 版权声明:大部分文章是从网上复制的!并不表示全部都是从网上复制的!
  • 感谢访问,请访问https://alipay.vnas.me领取支付宝红包
  • 如果遇到文章图片不显示请联系管理员处理,谢谢
  • 关于国内某个软件代理商代理的CorelDRAW系列软件,如果各位需要正版请访问corel官方网站,不要访问带有china的网站!!!反正话是放在这里了,听不听随你
  • 如果遇到文章图片不显示请联系管理员处理,谢谢

centos升级python到版本2.7.12并安装pip

技术类 大变态 7个月前 (05-23) 142次浏览 已收录 0个评论

最近使用 centos6 系列的系统安装酸酸乳的时候,在使用 pip 安装相关插件的时候总是提示错误,我想可能是 python 的问题吧~

注意:需要 root 权限

升级 python

查看 python 版本:

python --version

下载并解压 Python-2.7.12

wget https://www.python.org/ftp/python/2.7.12/Python-2.7.12.tgz
tar   zxvf   Python-2.7.12.tgz

安装必备插件

yum install gcc -y
yum -y install gcc-c++
yum -y install zlib*
yum install openssl-devel -y 

更改工作目录

cd Python-2.7.12  

安装

./configure --with-ssl
vi Module/Setup #zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz 去掉注释 zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz 这一步必须走,不然在下面安装 pip 会提示错误
make all make install make clean make distclean

查看版本信息

/usr/local/bin/python2.7 -V  

建立软连接,使系统默认的 python 指向 python2.7

mv /usr/bin/python /usr/bin/python2.6.6  
ln -s /usr/local/bin/python2.7 /usr/bin/python  

重新检验 Python 版本

python -V  

yum 出现了问题的解决方法

解决系统 Python 软链接指向 Python2.7 版本后,因为 yum 是不兼容 Python 2.7 的,所以 yum 不能正常工作,需要指定 yum 的 Python 版本
vi /usr/bin/yum
将文件头部的
#!/usr/bin/python
改成
#!/usr/bin/python2.6.6

安装 pip

在这里还是先升级一下,如果升级出现问题,再安装
pip install --upgrade pip

下载最新版的 pip,然后安装

wget https://bootstrap.pypa.io/get-pip.py
python get-pip.py

查找 pip 的位置

whereis pip

找到 pip2.7 的路径,为其创建软链作为系统默认的启动版本

ln -s /usr/local/bin/pip2.7 /usr/bin/pip

pip 安装完毕,现在可以用它下载安装各种包了 :)


本站大部分资源收集于网络,只做学习和交流使用,版权归原作者所有;若为付费内容,请在下载后 24 小时之内自觉删除,若作商业用途请购买正版;如果有版权争议,请发送邮件至 master@digac.cc(请留下写明原因和文章链接),我们将及时处理,谢谢!

喜欢 (0)
大变态
关于作者:
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址